British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an "Eddington number", E -- that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington's own E was 87.
Now given everyday's distances that one rides for N days, you are supposed to find the corresponding E (≤).
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.
Output Specification:
For each case, print in a line the Eddington number for these N days.
Sample Input:
10
6 7 6 9 3 10 8 2 7 8
Sample Output:
6
#include<stdio.h>
#include<algorithm>
using namespace std;
int seq[100005];
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int num;
scanf("%d",&num);
for(int i=0;i<num;i++)
{
scanf("%d",&seq[i]);
}
sort(seq,seq+num,cmp);
int out=0;
for(int i=0;i<num;i++) //必须从0 这时能判断第一个是否满足 即out=1才能判断
{ //否则out则是从0 到了2 中间1时是否正确无法判断
if(seq[i]>i+1)
{
out=i+1; //每次判断下一位的情况 若下一位不满足(不能等号 因为是more than ) 直接break 防止有重复数的判断错误
}else
{
break;
}
}
printf("%d",out);
}