The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N numbers are given in the next line, separated by one space.
Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number
where X
is the input. Then finally print in a line the result: The average of K numbers is Y
where K
is the number of legal inputs and Y
is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined
instead of Y
. In case K
is only 1, output The average of 1 number is Y
instead.
Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include<iostream>
#include<string>
using namespace std;
bool judge(string t)
{
bool reflag=false;
int dotloca=-1;
for(int i=0;i<t.size();i++)
{
if((t[i]>='0'&&t[i]<='9')||t[i]=='.'||t[i]=='-')
{
if(t[i]=='-'&&i!=0) return false;
// if(t[i]=='.'&&i==0) return false; //.在最前数据例子中暂无
if(t[i]=='.'&&dotloca!=-1) return false; //.在最后算对 故不要排除
if(t[i]=='.'&&dotloca==-1) dotloca=i;
if(dotloca!=-1&&i>dotloca+2) return false;
}
else
{
return false;
}
}
return true;
}
double intonum(string t)
{
double result=0;
double fh=1.0;
int start=0;
int dotwz=-1;
if(t[0]=='-')
{
fh=-1.0;
start=1;
}
for(int i=start;i<t.size();i++)
{
if(t[i]=='.') dotwz=i;
}
if(dotwz!=-1)
{
for(int j=start;j<dotwz;j++)
{
int n=t[j]-'0';
result=result*10;
result+=n;
}
double temp=0;
for(int j=t.size()-1;j>=dotwz+1;j--)
{
int n=t[j]-'0';
temp+=n;
temp=temp*0.1;
}
result+=temp;
}
else
{
for(int j=start;j<t.size();j++)
{
int n=t[j]-'0';
result=result*10;
result+=n;
}
}
return (result*fh);
}
int main()
{
int num;
cin>>num;
int count=0;
double sum=0;
for(int i=0;i<num;i++)
{
string temp;
cin>>temp;
bool flag=judge(temp);
if(flag==false)
{
cout<<"ERROR: "<<temp<<" is not a legal number"<<endl;
}
else
{
double mynum=intonum(temp);
if(mynum<=1000&&mynum>=-1000)
{
sum+=mynum;
count++;
}
else
{
cout<<"ERROR: "<<temp<<" is not a legal number"<<endl;
}
}
}
double result=sum/count;
if(count==0) printf("The average of 0 numbers is Undefined");
else if(count==1) printf("The average of %d number is %.2f",count,result); //注意s
else printf("The average of %d numbers is %.2f",count,result);
}