The following is from Max Howell @twitter:
Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
Now it's your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a -
will be put at the position. Any pair of children are separated by a space.
Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.
Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
vector<int> inorder;
vector<int>levelorder;
struct node
{
int leftchild=-1;
int rightchild=-1;
int father=-1;
}Node[15];
void myinorder(int root)
{
if(root==-1)return;
myinorder(Node[root].leftchild);
inorder.push_back(root);
myinorder(Node[root].rightchild);
}
void layerorder(int root)
{
queue<int> q;
q.push(root);
while(!q.empty())
{
int now=q.front();
q.pop();
levelorder.push_back(now);
if(Node[now].leftchild!=-1) q.push(Node[now].leftchild);
if(Node[now].rightchild!=-1) q.push(Node[now].rightchild);
}
}
int main()
{
int num;
char temp;
// scanf("%d",&num);
cin>>num;
for(int i=0;i<num;i++)
{
for(int j=0;j<2;j++)
{
cin>>temp;
// scanf("%c",&temp);
if(temp!='-' )
{
if(j==1)
{
Node[i].leftchild=temp-'0';
Node[(temp-'0')].father=i;
}
else
{
Node[i].rightchild=temp-'0';
Node[(temp-'0')].father=i;
}
}
}
}
int flag=0;
while(Node[flag].father!=-1)
{
flag=Node[flag].father;
}
myinorder(flag);
layerorder(flag);
int countlay=0;
while(countlay!=num)
{
if(countlay==0)
{
printf("%d",levelorder[countlay]);
}
else
{
printf(" %d",levelorder[countlay]);
}
countlay++;
}
printf("\n");
int count=0;
while(count!=num)
{
if(count==0)
{
printf("%d",inorder[count]);
}
else
{
printf(" %d",inorder[count]);
}
count++;
}
}